Page 1 of 1

5.0 Release Notes

PostPosted: Mon Jun 20, 2016 6:56 am
by TheeMahn
I have nothing but positive feedback of Ultimate Edition 5.0, uploading to Sourceforge...

EDIT: 09/11/16: Ultimate Edition 5.0.1 x64 is available for download, Ultimate Edition x86 5.0 is being built as I type this. X86 Available for download.
Building Ultimate Edition 5.0 x86

Pullting themes for 5.0 32 bit.

I feel will be a FAQ in 5.0:

Testing for compiz support in 5.0:
testing 1.png
compiz --replace

in a terminal or terminator

You can do this off the live disk to verify compatibility. If the top bar of the window does not work, you are pretty much screwed. Reboot and install there will be no compiz for you. Ultimate Edition 5.0 uses the most cutting edge Xorg there is, if it does not work here it will not work anywhere 16.04 etc. Feel free to chime in if you feel I am wrong. Crack Pushers Xorg PPA.

Adding compiz to automatically fire up on boot. After you have installed Ultimate Edition 5.0 Navigate to System > Preferences > Personal > Startup applications:
Startup Applications

Save, log out and login or reboot.

Feedback good or bad is appreciated. Thanks for at least trying Ultimate Edition !!! I will expand this when I can, working 3 jobs takes it's toll ;) I received a new title at work 2 weeks ago: MP2 Manager / Project Manager, why stop there I write software for them too. Underpaid there, but happy to have multiple incomes. Ultimate Edition is a very expensive hobby ;)


Re: 5.0 Release Notes

PostPosted: Tue Jun 21, 2016 1:12 am
by barney

Some feedback which I feel weird about as I know nothing about programing.

First, thank you for a very good OS, your hard work is appreciated.

Compiz in 5.0 is running CPU higher, this also happened with the official Ubuntu Mate 16.04, so it's not related to your build.

I also have no Ethernet connection with Ultimate Edition 5.0 which is odd given I have it with all other 16.04 releases, WIFI is fine.

The Kworker bug so far in Ultimate Edition is gone! So for that Sir I thank you.

When I try to add software through software and updates (other software) I get errors.

This is in my opinion the best Linux release of the year.

I will send you a beer. (well a donation)

Re: 5.0 Release Notes

PostPosted: Tue Jun 21, 2016 9:04 am
by speedstream
Hi Guys,

Just to let you know...

I just installed it and I am still discovering it.
There is one point I already noticed on the classic Ubuntu 16.04: the network performance with the Intel Gigabit Ethernet NIC embedded on my Z800 motherboard.
Performance divided by 2 !!!

Through UE4.6 (in fact through kernel 3.16 to 3.19) the minimum rate of transfer is around 80 MBytes/s. The peaks are around 100 MBytes and the average around 90 MB.
Through kernel 4.4: 48 MB... Impossible to reach more.

I have been testing this for weeks since I built up my Samba server (Debian 8.3 based). The rate of transfer was excellent with kernel 3.
No it's half of what it was.

So even if this is not specially linked with Ultimate Edition, I wish to share it just to know if people encounter the same problem and may have found a solution.

Except that, it looks to be a very good job. As usual :)

Re: 5.0 Release Notes

PostPosted: Wed Jun 22, 2016 2:26 am
by Wangbo
i too ran into the compiz problem on a whim after rebooting and resetting back to default i loaded the nvidia driver ( i have a nivida card installed) seemed to help the situation had tried earlier version (beta Ubuntu 16.04) and ran nividia driver with no problems until systemd updated a few times and after that and the newer kernel ( 4.4) seemed to get worse so maybe a combination of all three not playing well together but again a ubuntu problem have also tried and run mint with newer kernel ( again 4.4 ) in 17.3 Rosa with no problems at all running compiz with emerald , I have 4 different drives to play with so get to experiment and also helps to troubleshoot sometimes hope this helps the devs to figure this one out as im limited in my abilities.

Re: 5.0 Release Notes

PostPosted: Wed Jun 22, 2016 9:56 am
by Ken
I loaded version 5 onto a usb using Linux Mint's image writer, but the live session would not boot. Has anyone else had this problem? Does UNetbootin work?

Re: 5.0 Release Notes

PostPosted: Wed Jun 22, 2016 2:42 pm
by Ken
Ken wrote:I loaded version 5 onto a usb using Linux Mint's image writer, but the live session would not boot. Has anyone else had this problem? Does UNetbootin work?

I tried UNebootin which gave me a grub listing. Default selection did not work. Selected to try Ultimate Edition, which looked like it was working but that failed as well. I am still unable to boot the usb, any suggestions?

Re: 5.0 Release Notes

PostPosted: Wed Jun 22, 2016 5:20 pm
by Wangbo
Haven't been able to use either of what you mentioned for some time successfully but have been able to using Theemahns thumbos find the .deb file install it then in a terminal go to the directory contaning the iso file then issue the following command to install to a usb drive "sudo thumbos -l ultimate-edition-5.0-x64-lite-mate.iso sde
" sde being whatever the appropriate drive letter is for your usb drive then follow the commands and viola should work. The file you are looking for is utlimate_edition_thumbos_1.1.3.deb if can't find ask on here and someone should be able to direct you to it as i'm unsure how to attach it to this conversation or as to whether I'm allowed to

Re: 5.0 Release Notes

PostPosted: Thu Jun 23, 2016 12:26 am
by 2guntom

unetbootin works fine...

- - - - - - - - - -


I'm getting some weird errors.

W: Signature by key XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX uses weak digest algorithm (SHA1)
W: Signature by key XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX uses weak digest algorithm (SHA1)

I don't have a clue what that means

- - - - - - - - - -


I got the same Network Manager glitch after updating that I got in Xubuntu 16.04 and Chalet OS 16.04.
The glitch - after updating and restarting, all previous network connections are gone and there is no hope of connecting... to anything.
The only "fix" that works that I have found is to plug in a USB Wifi adaper; immediately networks become available. Connect to a network. Shut of the pc; remove adapter. Turn the pc back on and everything is normal again.

Actually, if memory serves, this glitch plagues 14.04 also... And, the LAST thing you want to do is Google for a solution. The 'buntu forums have a perfect fix that will render your distro completely useless if you follow it step by step.

- - - - - - - - - -


Hello Thee Man,

I appreciate what you are doing here - offering us Thee Distro. ;)

Re: 5.0 Release Notes

PostPosted: Fri Jun 24, 2016 3:30 pm
by OlDrunk
Great release! I'm glad to be switching to 5.0 from 3.4LTS , only bugs I've come across so far is "update-apt-xapian-index" crashes just about every login , the login screen graphically glitches out before dropping into desktop(minor issue), few times the system completely hanged on $ sudo reboot and had network manager(nm-applet) crash on me a couple of times lost the network icon but wi-fi connectivity remained, not sure if it is a compiz issue or what but MATE-panel has crashed a couple of times now adding or moving launcher icons, so far so good nothing major or really game breaking, I remember 3.4 had some issues in the beginning as well but cleared up after a few updates, so I'm not worried and confident in 5.0 being a fast and stable desktop on par with all other U.E releases.
Unrelated to U.E just a FYI - nvidia364/367 , 4.4kernel and xorg are not playing well together stick to 361 drivers or older till kernel 4.5/4.6 with xorg patch comes out or nvidia gets their $#!% together which ever comes first. I have a laptop with optimus so it was a real $#!% show for me with complete display loss and having to reinstall a few times.
Great Job on 5.0 and a cheers to TheeMahn, thanks for all the years of your hard work and time! I've been a loyal user of U.E since maverick.

Re: 5.0 Release Notes

PostPosted: Sat Jul 30, 2016 3:56 pm
by TheeMahn
I am going to attempt to answer questions all in one snap.
Don't sweat the load on:
W: Signature by key XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX uses weak digest algorithm (SHA1)

We (Ultimate Edition in general) actually have 2048 bit encryption and have had so almost since the beginning. Heavier encryption is not taken well by apt, same with Google. I have been building Operating Systems for a long minute. If I had as most have 512 kilobit encryption would not complain, we and I mean Google and I are on the top end.

"update-apt-xapian-index" crashes

This was a file I left stale on the O/S:

Code: Select all
sudo rm /var/crash/*
as root issue history. We use out own software center as it builds crashes, I did not clean it up 100% my fault. If I mess up I have 0 problems pointing out my faults.

I am not a kernel developer (though I could and have developed drivers), Compiz using more or less CPU I have no control over. I have written core based drivers for hardware, I am going to have to shun from being my fault,. I am sorry I have a bunch on my plate. Could you imagine having a job of Operating System Architect, my second job. On the compiz side I want to point out Wayland or Mir. It is coming unless I take drastic steps. Something I can do, I am far from powerless.

I do not mean to toot my own horn, but thumbos is the best app to load an O/S to a thumbdrive or SDCARD. I am working on enhancing it further to load Operating systems for a phone or Raspberry PI. Big things are coming ladies and gentlemen.