Are you a spammer

Please note, that the first 3 posts you make, will need to be approved by a forum Administrator or Moderator before they are publicly viewable.
Each application to join this forum is checked at the Stop Forum Spam website. If the email or IP address appears there when checked, you will not be allowed to join this forum.
If you get past this check and post spam on this forum, your posts will be immediately deleted and your account inactivated.You will then be banned and your IP will be submitted to your ISP, notifying them of your spamming. So your spam links will only be seen for an hour or two at most. In other words, don't waste your time and ours.

This forum is for the use and enjoyment of the members and visitors looking to learn about and share information regarding the topics listed. It is not a free-for-all advertising venue. Your time would be better spent pursuing legitimate avenues of promoting your websites.

Not booting

Help and support for Ultimate Edition 2.8

Not booting

Postby ralgha » Fri Mar 25, 2011 1:01 am


First of all, thank you for your releases though I'm pretty new on linux considering I had only installed Ultimate Edition 2.5 I had no problems whatsoever to sort out and my first linux experience was pretty fine. Some days ago I got a new HD (WD Black Caviar 2 TB) so I went for upgrading to your last release Ultimate Edition 2.9 (clean install) but after having it installed through a usb encased DVD drive and restarting, it just stated there was no bootable device. Since I needed the encased DVD drive to stay on my main pc drive for doing another windows install (same reason, same new HD), I went better for Ultimate Edition 2.8 since I could get it to work on unetbootin to be able to reinstall it as many times as needed using a USB stick. Long story short, same result. Got it installed with no problems but as soon as I restart it states the same "no bootable device found" or so.
I had tried different partition schemas: started out with a root ext4 partition (60 GB), one swap partition (2 GB) and an extended ext4 partition (the remaining space). Since it didn't worked and my previous install did use an ext2 for root and ext3 for extended, I then switch to ext2 and ext4, respectively. With the latter, I was able to boot by choosing my HD drive trough the Boot Device Menu or so it's called. That wouldn't bother too much if it weren't because I had to dig out for my old PS2 keyboard since the BIOS doesn't seem to detect my Microsoft Wireless Ergonomic 7000 keyboard at boot time at least, and wouldn't like to have both keyboards around just to be able to log into my linux pc. It should be noted I don't intend to use a windows+linux schema but a sole linux schema (it's a mini atx Intel DG41MJ based system, with 4 GB RAM, the 2TB HD I mentioned and I intend to use in a future a Vantec EZ swap sata drive for ext4 formated hd's for getting info back and forth my win pc and the linux pc).
I've tried the following steps posted on another site (booting from the unetbootin usb I used to install the Ultimate Edition 2.8):
sudo mount /dev/sda1 /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt

apt-get install grub-pc
grub-mkconfig -o /boot/grub/grub.cfg
grub-install /dev/sda (try grub-install --recheck /dev/sda if it fails)
Ctrl+D (to exit out of chroot)

sudo umount /mnt/dev
sudo umount /mnt

But when I get to the grub-install it states GRUB doesn't support GPT or so. Sorry, I had tried some other things like installing the efi x86 package instead of the grub-pc thinking it could get GRUB2 installed instead of GRUB-Legacy but then the grub-install /dev/sda doesn't work so I didn't copy the exact error messages and I'm not sure I would be getting the same ones now (and wouldn't like to reinstall everything up just yet - have been trying a few days now through local 4 am or so, and having to get to work a few hours later and I don't think I can hang in there once more hehe..
Is there something I'm doing wrong? Should it be a limitation from my MoBo or similar? Before I attempted installing the Ultimate Edition 2.9 distro I didn't know any of what I'm posting now so believe me I'm pretty new at this (my Ultimate Edition 2.5 install didn't ever go to a GRUB menu or so but when my pc was turned off due to external power failure and had to boot into safe mode or so to fix the superblock or so I believe it's called - had to do some research on the time since it was hanging at the logo).
I hope I can get some help from you to get this configured as it should. I'm pretty eager to get this done ASAP since I find myself more comfortable using the linux pc on a daily basis instead on my win pc (used mainly for gaming). Thanks!!

U.E. Newbie
U.E. Newbie
Posts: 2
Joined: Fri Mar 25, 2011 12:17 am
Operating System: Ultimate Edition 2.9 64 BIT

Re: Not booting

Postby pclinuxguru » Fri Mar 25, 2011 1:56 am

HDD set as main boot drive in bios?

Set as raid , ide , etc in bios ? Try IDE

Detailed specs of system would help.

Remember windows first then Ultimate Edition 2.9. Let grub do the work.

Installing from USB DVD is no problem. I do that one all the time.

Create your Shared files drive first, recommend NTFS to share with windows

2 to 3 gb swap

The rest ext4 primary first set as root / .

That easy. I suspect ether bad bios config, or DOA drive

Or bad install, bad cable etc.
pclinuxguru is deceased.R.I.P
U.E. God
U.E. God
Posts: 1712
Joined: Sun Oct 17, 2010 2:28 am
Age: 46
Operating System: Ubuntu Gusty Gibson

Re: Not booting

Postby ralgha » Mon Mar 28, 2011 11:30 pm

Thanks a lot for your quick response, sorry for not being able to get back to you before since this page is blocked at work and couldn't log in from another computer until now.

As to the answers, HDD has been set as main boot drive, as well as placed after USB and/or CD-ROM, none helped.
My BIOS has only one option regarding HDs and is Legacy or Native (SATA), and I have used both.

My system would be:
Intel DG41MJ Classic Series G41 mini-ATX Intel Graphics DVI+VGA 1333MHz LGA775 Desktop Motherboard
Intel Core 2 Duo E8400 3.0 GHz 6M L2 Cache 1333MHz FSB LGA775
Corsair TWIN2X4096-6400C5C 4GB XMS2 PC2-6400 800Mhz
Western Digital 2 TB Caviar Black SATA 7200 RPM 64 MB Hard Drive WD2001FASS
Thermaltake Element Q Mini-ITX Chassis with Built-in 200W SFX Power Supply

Regarding windows, I'm planning on having this system be only linux and not having several distros installed but the latest Ultimate Edition 2.9. I didn't know what was GRUB before stumbling with a not booting installation so it's until now I realize GRUB appears only when having more than one OS or distros, right?

What I did, is reinstalling using the whole disc (letting Ultimate Edition 2.8 do the partitions) and didn't work, so I went up to the BIOS and found out it had the option to enable UEFI boot (didn't know about GPT before so didn't know either what UEFI was). That did the trick and it could boot with no apparent problems.

Since I didn't quite like the partition Ultimate Edition did (no separate / and /home partitions) I decided to give it a try with Ultimate Edition 2.9 but now I'm stuck with a blinking cursor and nothing further.

I try defining the following partitions:
60 GB root partition (bootable) - ext2
1.9 TB (aprox) /home partition - ext4
2 GB swap partition

Thanks again for any insight!

Best regards,
U.E. Newbie
U.E. Newbie
Posts: 2
Joined: Fri Mar 25, 2011 12:17 am
Operating System: Ultimate Edition 2.9 64 BIT

Return to Ultimate Edition 2.8

Who is online

Users browsing this forum: No registered users and 1 guest