USB HDD refuses to spin up during boot (Solved)

Help & support for Ultimate Edition 1.8


USB HDD refuses to spin up during boot (Solved)

Postby csc2ya » Mon Oct 20, 2008 10:25 am

I've got an odd problem with the (external) drive that Ultimate Edition is installed on.

The way i've got my laptop configured is to bring up the vista bootloader first when it's turned on. That then has an entry for vista, and a entry that starts grub. Once grub is loaded, it then boots the first entry after 1 second.

Both grub, and Ultimate Edition are on an external USB drive. Lately when booting, the drive has spun up in the bios, but when Ultimate Edition starts looking for the files needed to boot, it doesn't always seem to spin up.

I have usually been able to get round this by booting in recovery mode, which before now, the drive has always spun up in, but today when I tried the same thing, I just got an error along the lines of:

Cannot read port 7. Maybe the USB cable is bad.

i eventually got it to boot, but it took almost 20 tries.

The odd thing is, it always spins up in windows, and once it has spun up during the boot of Ultimate Edition, it's usually fine after that. It only seems to be if my laptop's been off for a while that it won't work, so i'm not 100% sure that the hardware has gone bad

I've tried a different USB cable, and also tried a different port on my USB hub, but that doesn't make any difference. I've also tried it plugged directly into my laptop, but I get the same error on all USB ports.

Has anyone got any idea on either how to get it working properly again, or (this is probably a long shot), a way to stop Ultimate Edition resetting the USB ports when it boots, as, as I said above, the drive always spins up during the BIOS portion of the boot.
Last edited by csc2ya on Wed Oct 22, 2008 2:46 pm, edited 2 times in total.
Craig Turner
Computing Support Centre Administrator
System Status
Laptop
Image
Server
Image
User avatar
csc2ya
U.E. Knowledgable
U.E. Knowledgable
 
Posts: 44
Joined: Thu Jul 24, 2008 1:49 pm
Age: 33
Operating System: Ultimate Edition 2.6 64 BIT



Re: USB HDD Intermittently refuses to spin up during boot

Postby pch.shot » Mon Oct 20, 2008 12:33 pm

When hard drives start to go, they behave very strangely!! You could try another hard drive just to check. Re-install your usb driver. If you don't have the motherboard install disc just go to the web site of the mobo manufacturer and they should have all the lastest drivers. Since you are running windows you can download and install this: http://pc-wizard-2008.en.softonic.com/
It will give you all the details about your computer.
Systems Windows XP Pro 32 bit & various Linux in Virtual Box and VMWare Player
Intel i7 2600K cpu with built in Intel 3000 video
1 OCZ Vertex 3 120 gig ssd(System)
1 Western Digital 2 Terabyte Green internal hard drive(Storage)
Kingston ddr3 1333 ram(4 gig)
MSI Z68A-GD80(G3)mobo w/hdmi video and optical audio
Realtek HD audio
Realtek lan
1 LG sata optical drive
Antec Sonata IV case/620 watt psu
50 inch LG plasma tv/monitor
Sony surround sound amp
Axiom speakers
optical sound
User avatar
pch.shot
U.E. God
U.E. God
 
Posts: 3685
Joined: Sat Feb 02, 2008 12:28 pm
Location: Chippawa, Canada
Age: 64
Operating System: Microsoft Windows



Re: USB HDD Intermittently refuses to spin up during boot

Postby csc2ya » Tue Oct 21, 2008 8:54 am

It looks like it wasn't the drive after all. I tried booting up today and it wouldn't work again. I rebooted and went into windows, and was getting an error about 'a device attatched to this computer has malfunctioned'

I unplugged the drive and plugged it back in....same error. Unplugged it again, and the error stayed. I then unplugged my mouse reciever, which I know works, and the message dissapeared.

I tried the mouse reciever on it's own, and got the message again, along with a non working mouse.

I then thought: 'It's unlikely that two devices could have failed at the same time, but not impossible'

I plugged both my external HD and my mouse reciever into the ports on my laptop, and hey presto. Found new hardware, mouse working again, drive spins up.

Rebooted into linux with them connected like that, and it worked first time, so it was either my USB hub, or possibly the cable between the hub and my laptop.

I'm going to try it with a different cable later on to check it if I can find one that fits it,but i'm pretty sure it is the cable, since that's given me problems in the past.
Craig Turner
Computing Support Centre Administrator
System Status
Laptop
Image
Server
Image
User avatar
csc2ya
U.E. Knowledgable
U.E. Knowledgable
 
Posts: 44
Joined: Thu Jul 24, 2008 1:49 pm
Age: 33
Operating System: Ultimate Edition 2.6 64 BIT



Re: USB HDD Intermittently refuses to spin up during boot

Postby csc2ya » Tue Oct 21, 2008 9:02 am

How do I mark a thread as solved? I'm sure there used to be a button to do it, but I can't seem to find it now.
Craig Turner
Computing Support Centre Administrator
System Status
Laptop
Image
Server
Image
User avatar
csc2ya
U.E. Knowledgable
U.E. Knowledgable
 
Posts: 44
Joined: Thu Jul 24, 2008 1:49 pm
Age: 33
Operating System: Ultimate Edition 2.6 64 BIT



Re: USB HDD Intermittently refuses to spin up during boot

Postby deate » Tue Oct 21, 2008 9:19 am

csc2ya wrote:How do I mark a thread as solved? I'm sure there used to be a button to do it, but I can't seem to find it now.

Do you not have an edit...quote..and other buttons to the right of your "Title " of your post? If you have edit click that, then add "Solved" to the title line of your post...I'd do it for you, but then you don't learn...try it :D
User avatar
deate
Site Admin
 
Posts: 1336
Joined: Tue Dec 18, 2007 9:54 am
Location: South Texas
Age: 69
Operating System: Ultimate Edition 3.0 Lite



Re: USB HDD Intermittently refuses to spin up during boot

Postby pch.shot » Tue Oct 21, 2008 11:37 am

I hate hardware!! There, I've said it!! Glad you got it all working.
Systems Windows XP Pro 32 bit & various Linux in Virtual Box and VMWare Player
Intel i7 2600K cpu with built in Intel 3000 video
1 OCZ Vertex 3 120 gig ssd(System)
1 Western Digital 2 Terabyte Green internal hard drive(Storage)
Kingston ddr3 1333 ram(4 gig)
MSI Z68A-GD80(G3)mobo w/hdmi video and optical audio
Realtek HD audio
Realtek lan
1 LG sata optical drive
Antec Sonata IV case/620 watt psu
50 inch LG plasma tv/monitor
Sony surround sound amp
Axiom speakers
optical sound
User avatar
pch.shot
U.E. God
U.E. God
 
Posts: 3685
Joined: Sat Feb 02, 2008 12:28 pm
Location: Chippawa, Canada
Age: 64
Operating System: Microsoft Windows



Re: USB HDD Intermittently refuses to spin up during boot

Postby csc2ya » Wed Oct 22, 2008 2:54 pm

deate wrote:
csc2ya wrote:How do I mark a thread as solved? I'm sure there used to be a button to do it, but I can't seem to find it now.

Do you not have an edit...quote..and other buttons to the right of your "Title " of your post? If you have edit click that, then add "Solved" to the title line of your post...I'd do it for you, but then you don't learn...try it :D


Thanks. I was thinking of the Ubuntu forums where there's a radio button that marks it as solved when you edit the post.

I did actually really badly mess up today with ultimate edition. I decided to install macosx kalyway as well as a triple boot. Booted into windows to resize my data partition. For some really stupid reason, Instead of doing that, I saw an unrecognized partition on my external drive, and deleted it. Then immediately realized that i'd just removed my linux partition :(

I then searched for ways to recover it. First program I tried crashed while scanning the now empty space on the drive.

Then I remembered testdisk, and downloaded the windows version. Ran that on the now unallocated space: ext3 partition found. Rewrote that to the empty space, rebooted, and Ultimate edition is back, and working perfectly, along with all my data.

(*makes a note*: Triple check what you're deleting BEFORE you delete it)
Craig Turner
Computing Support Centre Administrator
System Status
Laptop
Image
Server
Image
User avatar
csc2ya
U.E. Knowledgable
U.E. Knowledgable
 
Posts: 44
Joined: Thu Jul 24, 2008 1:49 pm
Age: 33
Operating System: Ultimate Edition 2.6 64 BIT



Re: USB HDD refuses to spin up during boot (Solved)

Postby csc2ya » Fri Dec 26, 2008 8:55 pm

One last update to this: It appears it was the drive after all. I've now got a new external drive, which i've installed ultimate edition on, then moved my home folder across. This spins up every time. Only downside is that it takes longer to spin up than the old one, so I have to restart my laptop to get it to boot after turning it on. However, that's better than having to keep turning the drive on and off, which was starting to get annoying.

There's also the benefit of the drive being bigger (1TB rather than 250GB). I now have a 472GB linux partition where before it was only 119GB. Haven't been able to get the vista bootloader to bring up grub yet, so the drive has to be connected to boot any OS on my internal drive as well, as it boots to grub first, but since my laptop is never moved, that's not a problem.

Thanks for all the help and suggestions.
Craig Turner
Computing Support Centre Administrator
System Status
Laptop
Image
Server
Image
User avatar
csc2ya
U.E. Knowledgable
U.E. Knowledgable
 
Posts: 44
Joined: Thu Jul 24, 2008 1:49 pm
Age: 33
Operating System: Ultimate Edition 2.6 64 BIT


Return to Ultimate Edition 1.8

Who is online

Users browsing this forum: No registered users and 3 guests