Are you a spammer

Please note, that the first 3 posts you make, will need to be approved by a forum Administrator or Moderator before they are publicly viewable.
Each application to join this forum is checked at the Stop Forum Spam website. If the email or IP address appears there when checked, you will not be allowed to join this forum.
If you get past this check and post spam on this forum, your posts will be immediately deleted and your account inactivated.You will then be banned and your IP will be submitted to your ISP, notifying them of your spamming. So your spam links will only be seen for an hour or two at most. In other words, don't waste your time and ours.

This forum is for the use and enjoyment of the members and visitors looking to learn about and share information regarding the topics listed. It is not a free-for-all advertising venue. Your time would be better spent pursuing legitimate avenues of promoting your websites.

Alien Arena installation (64bit)...[SOLVED]

Help & support for Ultimate Edition 2.6


Alien Arena installation (64bit)...[SOLVED]

Postby Wolfie Lee » Tue Aug 03, 2010 12:49 pm

Hello, the newest version of Alien Arena is out (within the last week), and I'm having problems getting it installed....those on the AA forum site are a bit slo-o-o-ow in helping out. Here is what I've posted there, can anyone see a problem they can help with? Please...?

posted:

"OH, Great ... I have a 64bit system, and read at the bottom of page one of this thread that I need to recompile!??!?!? Here's what I've done so far: I went into the source folder and did the make install, and now I can't find the program in the applications/games menu, so then I tried again to open a terminal in crx, then tried the ./crx command again, and I still get the same thing I always have, which is the following mesasge:

./crx: error while loading shared libraries: libXxf86dga.so.1: cannot open shared object file: No such file or directory

I have NEVER "Recompiled" anything, just used synaptic, or downloaded a .deb package, which automatically gives an option to install directly from download dialog. Can you walk me through what I need to do to maybe get rid of what I've done, if needed, then to get it recompiled, AND Fully installed, where it is in the app./games menu? OOPS..Scratch that...just tried running make install again, and after about 45 seconds of running in terminal, I get this...

client/snd_openal.c:2775: error: ‘sfx_t’ has no member named ‘name’
client/snd_openal.c:2778: error: ‘sfx_t’ has no member named ‘name’
client/snd_openal.c:2784: error: ‘sfx_t’ has no member named ‘aliased’
client/snd_openal.c:2784: error: ‘sfx_t’ has no member named ‘truename’
client/snd_openal.c:2784: error: ‘sfx_t’ has no member named ‘name’
make[1]: *** [release/client/snd_openal.o] Error 1
make[1]: Leaving directory `/home/alienarena7_45-Linux20100726/alienarena7_45/source'
make: *** [build-release] Error 2
root@bruce-desktop:/home/alienarena7_45-Linux20100726/alienarena7_45/source#

I'm pretty sure that happened the first time I ran make install, but I closed the terminal and tried to find it in the games menu without looking at the last few lines of terminal messages...where to go from here...? p.s. I run Ultimate Edition 2.6...based in Ubuntu 9.10...if it makes a difference"

P.S.
Yes, synaptic shows OpenAL shared library as installed....
Last edited by Wolfie Lee on Wed Aug 04, 2010 2:43 am, edited 1 time in total.
OS: Ultimate Edition 4.6 gamers x64; Windows 7 x64 custom Nvidia Black edition; Linux Mint 17.3 MATE x64
MB: Gigabyte 970A-DS3P
CPU: AMD FX6300 Black (6x 3.5GHz)
CPU cooler: OCZ Vedetta with replacement Nanoxia Deep Silence 92mm 1400 RPM fan
MEM: 8GB (2x4GB) Ballistix Sport DDRIII 1600; PC3-12800
GPU: XFX Double Dispersion Radeon R7 360P-F22M 1050MHz 2GB GDDR5
OS SSD: Samsung 850 EVO 500GB
NO Storage drive (yet)
Optical Drive: LG Super-multi with MODISC capabilities(Model# hidden in new build, not gonna remove it now...lol)
Optical Drive: Samsung SH-5183
PS: XFX 650W XXX Edition Grey Modular
Image
User avatar
Wolfie Lee
U.E. Pro
U.E. Pro
 
Posts: 193
Joined: Fri Dec 05, 2008 4:05 am
Location: Niles, MI, USA
Age: 51
Operating System: Ultimate Edition 3.0 Lite Gamers



Re: Alien Arena installation...

Postby Cell » Wed Aug 04, 2010 2:05 am

Run it from a terminal?To make sure its installed.
-------------------------------
hardware
--------------------------------
Dfi lanparty ut rdx200cf-dr
amd athlon 64 fx55 oc 2.9
2xvisiontek x1600xt gamers ed.
3 gig kingston hyperx mem
hauppauge win tv go tuner
pinnacle ultimate hd hybrid usb tuner
1 western hd 100 gig drive
1 western hd 160 gig drive
1 western hd 5 gig drive
1 usb hd 150 gig
1 usb hd 1 terabyte
--------------------
OS/Distros
--------------------
PhatDebian 1.0
StonerEdition 2.0
Ultimate Edition 2.4 Gamer Ed.
Mythbuntu 9.10
windows XP MCE remastered with Nlite
Windows 7 remastered with Vlight
----------------------------------------------------------
We are all connected;
To each other, biologically
To the earth, chemically
To the rest of the universe atomically-deGrasse Tyson
User avatar
Cell
Site Admin
 
Posts: 1817
Joined: Tue Dec 23, 2008 7:43 pm
Location: Repuplic of California,U.S.A.
Age: 46
Operating System: Ultimate Edition 1.8 Gamers



Re: Alien Arena installation for 64bit...[SOLVED]

Postby Wolfie Lee » Wed Aug 04, 2010 2:43 am

No... I did have to recompile it...for anyone else looking to run it in 64bit, here's the skinny:

1.) Download from here: http://icculus.org/alienarena/rpa/aquire.html#tag2 ...extract to your home folder

2.) Follow this guide for dependencies, and re-compilation:

http://ubuntuforums.org/showpost.php?p= ... ostcount=7

(IF you get any permission denied messages, tag each code entry with sudo, first, That's what I had to do)

3.) Open terminal in the alienarena7_45 Directory (where the crx file is located) and run "./crx" without quotes

4.) Go Get Ya SOME!

The Linux guy (or ONE of them) at the AA forums dug it up for me...up and running with a crippled launcher...but I'll get that taken care of, too eventually, and post steps for that as well...meantime I'll just open it in terminal.
OS: Ultimate Edition 4.6 gamers x64; Windows 7 x64 custom Nvidia Black edition; Linux Mint 17.3 MATE x64
MB: Gigabyte 970A-DS3P
CPU: AMD FX6300 Black (6x 3.5GHz)
CPU cooler: OCZ Vedetta with replacement Nanoxia Deep Silence 92mm 1400 RPM fan
MEM: 8GB (2x4GB) Ballistix Sport DDRIII 1600; PC3-12800
GPU: XFX Double Dispersion Radeon R7 360P-F22M 1050MHz 2GB GDDR5
OS SSD: Samsung 850 EVO 500GB
NO Storage drive (yet)
Optical Drive: LG Super-multi with MODISC capabilities(Model# hidden in new build, not gonna remove it now...lol)
Optical Drive: Samsung SH-5183
PS: XFX 650W XXX Edition Grey Modular
Image
User avatar
Wolfie Lee
U.E. Pro
U.E. Pro
 
Posts: 193
Joined: Fri Dec 05, 2008 4:05 am
Location: Niles, MI, USA
Age: 51
Operating System: Ultimate Edition 3.0 Lite Gamers


Return to Ultimate Edition 2.6 (Including 2.6.5)

Who is online

Users browsing this forum: No registered users and 1 guest