[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4758: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4759: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4760: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
Ultimate Edition Forum • View topic - wine issues + playonLinux post here please.
Page 1 of 1

Re: wine issues + playonLinux post here please.

PostPosted: Wed Apr 14, 2010 11:30 am
by TexasMike
Hello all,
I want to be able to run/play my R/C Simulator on Ultimate Edition 2.5X64 .
I am able to install the software directly into Wine by simply Right-clicking on the "Setup.exe" file on the CD and it installs without any error messages. My experience has been good with programs that had no errors during the installation, but this one is giving me a problem...

The next step in the installation of this program is to "Register" the serial numbers of the software and it's "Hardware" - an R/C "Transmitter" (actually only a controller with joysticks that looks and responds like the actual transmitter used to fly R/C Models). And this is where I run into problems - I can enter the appropriate numbers/information as requested by the program (see 1st screenshot below), but it always fails to recognise the input and goes to a screen asking for the serial numbers (see the 2nd screenshot below).

G5-1.png

G5-2.png

I did check with WineHQ and the Wine AppDB, and found where someone had tried to install 2 older versions of RealFlight (G3 & G4)- the results were that it seemed to install OK, but I did not "Launch" the program. Not much else there about this program.
I am hoping that someone here has more experience with WINE (or even Play-On-Linux) and can help me resolve this problem. Is there an error log for WINE, and if so, where is it located?
BTW: The requirements for this program are:
Minimum Recommended System: Win XP/Vista/WIN7, Pentium 1.ooGHz, 512MB RAM, 4GB Drive Space, DVD Drive, 3D Accelerated Video with 32MB dedicated memory& full Windows DirectX9 compliant (Pixel Shader 1.4 support).
Optimal System: Dual Core 2.4GHz CPU, 2GB RAM, 3D Accelerated Video with 512 MB Dedicated memory, Pixel Shader 3.0 support.

I can run this application in Win7 Ultimate X64 on the same system Hardware) I am trying to get it to run under Ultimate Edition 2.5X64, and it works perfectly in Win7 of course.

Anyone got any ideas, suggestions for troubleshooting this problem? I'd even like to try to get it going under Play-On-Linux, but the documentation I can find is pretty sparse, see this URL: .

Re: wine issues + playonLinux post here please.

PostPosted: Wed Apr 14, 2010 12:16 pm
by Admin-Amir

Re: wine issues + playonLinux post here please.

PostPosted: Wed Apr 14, 2010 6:07 pm
by TexasMike
Amir,
I tried following your suggestions and opened the Guide for instructions... My copy is version "xCHM v. 1.17" - this is what I see under Help>About when I look at the version of the Guide:
Guide-1.png

And my version of PlayOnLinux is 3.7.3, and the Guide is nearly unreadable in many places - see my screenshot below:
PlayONLinux-1.png

I was able to install Internet Explorer 7 per the instructions in the guide - with a little "guessing" as to what the guide said I should be doing. However, I do not see how this will help with RealFlight G5, as it is NOT in the list of PlayOnLinux programs which are known to work. (That would be too easy!!) :shock:
As I said in my previous post, I was able to get the program installed directly into WINE without errors, but the "Registration" of the hardware with the software is where it fails, and continues to prompt for those registration numbers before the Game/Simulator will run. :o
I was hoping someone could point me to some sort of log file or error file that might help me to find what was causing the program NOT to accept the registrations numbers - there is NEVER any sort of error message, it just repeatedly goes to the 2nd screen shown in my previous post - asking for the "Serial Numbers" to be entered.
As far as doing an Install a of an unsupported application in POL, I am not familiar with that procedure, and the official documentation is pretty sparse, and not much help to me with this procedure. :(
I am open to suggestions and any "Try This" suggestions that sound reasonable... This sort of problem is what needs to be solved in order to bring even more users to Linux/Ultimate Edition, and have them leave WinDoze behind once and for all! That is my goal with Ultimate Edition, and I hope I can make it a reality, at least for myself.
I only use Win for a few games - RealFlight, MS FlightSim 2004, and my HP ScanJet 5300C USB flatbed scanner (which has miraculessly started working in Ultimate Edition 2.5 after a recent update - not sure which one because I sort of "discovered": that it works now, by accidentally clicking on XSane, and it came up, found the correct scanner, and allowed me to scan and save normally!!). <BREW>
Anyway, any help you or anyone else can offer would be appreciated.... ;)

NOTE: I am wondering if the RealFlight program is "seeing" the USB connected "controller/transmitter"...?? If not, that might be the problem with the continued failure of the "Registration" process of the software with the hardware... I do not know how to check if the hardware is being seen by WINE - or even by Ultimate Edition for that matter...
Any more ideas ...?? :?

Re: wine issues + playonLinux post here please.

PostPosted: Wed Apr 14, 2010 11:15 pm
by Cell
TexasMike,
I found this don't know if you read it or not.But it looks bleak for the present.

http://www.knifeedge.com/forums/archive ... 24534.html

Re: wine issues + playonLinux post here please.

PostPosted: Thu Apr 15, 2010 2:22 am
by Admin-Amir
Hello Cell & TexasMike

it looks like Cell is right Bro.
I can say that when I have run the installation process of the Game "IAF" The Israeli Game.
I know in 100% there is Virus on the process of the installation that open the Directory on your system.
Well How I know that?
Avast Anti Virus Alert on it right away.
The process can not go on - get the Anti Virus off and you can go on,
But as you know that is Good for the MS PPL not for us.
So if I think here on your Game it looks the same Issue with kind of open backdoor on the system for the registration.

But First lets try all the work around to make sure we did all the steps needed from the system to be ready.

1- start with the wine Guide and see that all done there right:
viewtopic.php?f=7&t=3785

2- here is the link to the playonLinux on my process of the get it done with the fonts and Explorer .....
BTW - bro if you click in your blog on the PlayonLinux it will get you to my Picasa screen shots.

http://picasaweb.google.com/mypoolgame/ ... xTheGuide#


3- After you will make all on those 2 process , you will have to un install the Game First from the wine.
Then Delete the file from the program files on wine.
Then please run the Anti Virus on the Path of the Directory on wine.

4- after you will Restart the machine at the end of all above , see if you can install the Game.
If you will have the same Results then it looks like Cell & myself are right on this issue.
send me PM please - I will Guide you to one more way.