wine issues + playonLinux post here please.

Help and support for Ultimate Edition 2.5


Re: wine issues + playonLinux post here please.

Postby TexasMike » Wed Apr 14, 2010 11:30 am

Hello all,
I want to be able to run/play my R/C Simulator on Ultimate Edition 2.5X64 .
I am able to install the software directly into Wine by simply Right-clicking on the "Setup.exe" file on the CD and it installs without any error messages. My experience has been good with programs that had no errors during the installation, but this one is giving me a problem...

The next step in the installation of this program is to "Register" the serial numbers of the software and it's "Hardware" - an R/C "Transmitter" (actually only a controller with joysticks that looks and responds like the actual transmitter used to fly R/C Models). And this is where I run into problems - I can enter the appropriate numbers/information as requested by the program (see 1st screenshot below), but it always fails to recognise the input and goes to a screen asking for the serial numbers (see the 2nd screenshot below).

G5-1.png


G5-2.png


I did check with WineHQ and the Wine AppDB, and found where someone had tried to install 2 older versions of RealFlight (G3 & G4)- the results were that it seemed to install OK, but I did not "Launch" the program. Not much else there about this program.
I am hoping that someone here has more experience with WINE (or even Play-On-Linux) and can help me resolve this problem. Is there an error log for WINE, and if so, where is it located?
BTW: The requirements for this program are:
Minimum Recommended System: Win XP/Vista/WIN7, Pentium 1.ooGHz, 512MB RAM, 4GB Drive Space, DVD Drive, 3D Accelerated Video with 32MB dedicated memory& full Windows DirectX9 compliant (Pixel Shader 1.4 support).
Optimal System: Dual Core 2.4GHz CPU, 2GB RAM, 3D Accelerated Video with 512 MB Dedicated memory, Pixel Shader 3.0 support.

I can run this application in Win7 Ultimate X64 on the same system Hardware) I am trying to get it to run under Ultimate Edition 2.5X64, and it works perfectly in Win7 of course.

Anyone got any ideas, suggestions for troubleshooting this problem? I'd even like to try to get it going under Play-On-Linux, but the documentation I can find is pretty sparse, see this URL: http://www.playonlinux.com/en/page-2-Documentation.html.
Shop PC:
Motherboard: ASUS Sabertooth 990FX TUF (The Ultimate Force) R2.0
CPU: AMD FX 9370 @ 4.4GHz Bulldozer Eight Core Black Edition
Ram: 16GB Corsair Vengance Dual Channel DDR3 1600MHz
Video: ATI 7770HD GHZ Edition 2GB PCIe 3.0
Hard Drives: Seagate 2TB, Seagate 500GB, Maxtor 500GB
SSD Drives: OCZ-Vertex4 128GB, Samsung SSD 840 EVO 500GB
DVD Drive: Plextor PX-L890SA
Power Suipply: RaidMax Modular 1200Watt
OS: Ultimate Edition 3.4.2x64, 4.2x64, 2.6x7x64

Home:
Motherboard:Gigabyte GA-Z77-DS3
CPU: Intel Core i3-3220 3.3ghZ
RAM: 8GB DDR3 1600MHz
Video: nVdia GTX650
Drives:1TB SATAIII, 2ea 500GB SATAIII,
SSD: Samsung EV840 mSATa 250GB
CD/DVD: Plextor PL-890SA
Monitor: Samsung SyncMaster T260
MultiBoot OS: Ultimate Edition 3.4.2x64, 4.2x64-Lite, WIN7x64, WIN8.1x64
Power Supply: Corsair 850Watt
User avatar
TexasMike
Site Admin
 
Posts: 523
Joined: Sat Oct 27, 2007 7:07 pm
Location: North of Houston Texas
Age: 68
Operating System: Ultimate Edition 3.2 64 BIT



Re: wine issues + playonLinux post here please.

Postby Admin-Amir » Wed Apr 14, 2010 12:16 pm

Hello TexasMike.

First of all I hope you've all installations are required on PlayonLinux (Look on the Guide) incloud Direct X .
And you have configure wine right (you can see on the How To my option there).
Then hope the next part will get get things going for you.

Here:
http://ubuntuforums.org/showthread.php?t=684561

G5 System Requirements

Minimum Recommended System:

Some graphical features may be disabled. Aerodynamic calculations will remain high quality.
Windows* XP, Windows* Vista® or Windows* 7
*Local administrator access required.
Intel® Pentium® 1.0GHz or equivalent
512 MB RAM
4 GB Hard Drive Space
DVD Drive
3D Accelerated Video with: 32 MB Dedicated Video Memory Full Windows DirectX® 9 compliant (Pixel Shader 1.4 support)

Optimal System:

For best graphical performance
Dual Core 2.4GHz CPU
2 GB RAM
3D Accelerated Video with: 512 MB dedicated video memory Pixel Shader 3.0 support



BTW - it looks like it works with Cedega.

If it will not give you the solution we will work on it to get it done for you :D
Admin-Amir
 



Re: wine issues + playonLinux post here please.

Postby TexasMike » Wed Apr 14, 2010 6:07 pm

Amir,
I tried following your suggestions and opened the Guide for instructions... My copy is version "xCHM v. 1.17" - this is what I see under Help>About when I look at the version of the Guide:
Guide-1.png


And my version of PlayOnLinux is 3.7.3, and the Guide is nearly unreadable in many places - see my screenshot below:
PlayONLinux-1.png


I was able to install Internet Explorer 7 per the instructions in the guide - with a little "guessing" as to what the guide said I should be doing. However, I do not see how this will help with RealFlight G5, as it is NOT in the list of PlayOnLinux programs which are known to work. (That would be too easy!!) :shock:
As I said in my previous post, I was able to get the program installed directly into WINE without errors, but the "Registration" of the hardware with the software is where it fails, and continues to prompt for those registration numbers before the Game/Simulator will run. :o
I was hoping someone could point me to some sort of log file or error file that might help me to find what was causing the program NOT to accept the registrations numbers - there is NEVER any sort of error message, it just repeatedly goes to the 2nd screen shown in my previous post - asking for the "Serial Numbers" to be entered.
As far as doing an Install a of an unsupported application in POL, I am not familiar with that procedure, and the official documentation is pretty sparse, and not much help to me with this procedure. :(
I am open to suggestions and any "Try This" suggestions that sound reasonable... This sort of problem is what needs to be solved in order to bring even more users to Linux/Ultimate Edition, and have them leave WinDoze behind once and for all! That is my goal with Ultimate Edition, and I hope I can make it a reality, at least for myself.
I only use Win for a few games - RealFlight, MS FlightSim 2004, and my HP ScanJet 5300C USB flatbed scanner (which has miraculessly started working in Ultimate Edition 2.5 after a recent update - not sure which one because I sort of "discovered": that it works now, by accidentally clicking on XSane, and it came up, found the correct scanner, and allowed me to scan and save normally!!). <BREW>
Anyway, any help you or anyone else can offer would be appreciated.... ;)

NOTE: I am wondering if the RealFlight program is "seeing" the USB connected "controller/transmitter"...?? If not, that might be the problem with the continued failure of the "Registration" process of the software with the hardware... I do not know how to check if the hardware is being seen by WINE - or even by Ultimate Edition for that matter...
Any more ideas ...?? :?
Shop PC:
Motherboard: ASUS Sabertooth 990FX TUF (The Ultimate Force) R2.0
CPU: AMD FX 9370 @ 4.4GHz Bulldozer Eight Core Black Edition
Ram: 16GB Corsair Vengance Dual Channel DDR3 1600MHz
Video: ATI 7770HD GHZ Edition 2GB PCIe 3.0
Hard Drives: Seagate 2TB, Seagate 500GB, Maxtor 500GB
SSD Drives: OCZ-Vertex4 128GB, Samsung SSD 840 EVO 500GB
DVD Drive: Plextor PX-L890SA
Power Suipply: RaidMax Modular 1200Watt
OS: Ultimate Edition 3.4.2x64, 4.2x64, 2.6x7x64

Home:
Motherboard:Gigabyte GA-Z77-DS3
CPU: Intel Core i3-3220 3.3ghZ
RAM: 8GB DDR3 1600MHz
Video: nVdia GTX650
Drives:1TB SATAIII, 2ea 500GB SATAIII,
SSD: Samsung EV840 mSATa 250GB
CD/DVD: Plextor PL-890SA
Monitor: Samsung SyncMaster T260
MultiBoot OS: Ultimate Edition 3.4.2x64, 4.2x64-Lite, WIN7x64, WIN8.1x64
Power Supply: Corsair 850Watt
User avatar
TexasMike
Site Admin
 
Posts: 523
Joined: Sat Oct 27, 2007 7:07 pm
Location: North of Houston Texas
Age: 68
Operating System: Ultimate Edition 3.2 64 BIT



Re: wine issues + playonLinux post here please.

Postby Cell » Wed Apr 14, 2010 11:15 pm

TexasMike,
I found this don't know if you read it or not.But it looks bleak for the present.

http://www.knifeedge.com/forums/archive ... 24534.html
-------------------------------
hardware
--------------------------------
Dfi lanparty ut rdx200cf-dr
amd athlon 64 fx55 oc 2.9
2xvisiontek x1600xt gamers ed.
3 gig kingston hyperx mem
hauppauge win tv go tuner
pinnacle ultimate hd hybrid usb tuner
1 western hd 100 gig drive
1 western hd 160 gig drive
1 western hd 5 gig drive
1 usb hd 150 gig
1 usb hd 1 terabyte
--------------------
OS/Distros
--------------------
PhatDebian 1.0
StonerEdition 2.0
Ultimate Edition 2.4 Gamer Ed.
Mythbuntu 9.10
windows XP MCE remastered with Nlite
Windows 7 remastered with Vlight
----------------------------------------------------------
We are all connected;
To each other, biologically
To the earth, chemically
To the rest of the universe atomically-deGrasse Tyson
User avatar
Cell
Site Admin
 
Posts: 1817
Joined: Tue Dec 23, 2008 7:43 pm
Location: Repuplic of California,U.S.A.
Age: 44
Operating System: Ultimate Edition 1.8 Gamers



Re: wine issues + playonLinux post here please.

Postby Admin-Amir » Thu Apr 15, 2010 2:22 am

Hello Cell & TexasMike

it looks like Cell is right Bro.
I can say that when I have run the installation process of the Game "IAF" The Israeli Game.
I know in 100% there is Virus on the process of the installation that open the Directory on your system.
Well How I know that?
Avast Anti Virus Alert on it right away.
The process can not go on - get the Anti Virus off and you can go on,
But as you know that is Good for the MS PPL not for us.
So if I think here on your Game it looks the same Issue with kind of open backdoor on the system for the registration.

But First lets try all the work around to make sure we did all the steps needed from the system to be ready.

1- start with the wine Guide and see that all done there right:
viewtopic.php?f=7&t=3785

2- here is the link to the playonLinux on my process of the get it done with the fonts and Explorer .....
BTW - bro if you click in your blog on the PlayonLinux it will get you to my Picasa screen shots.

http://picasaweb.google.com/mypoolgame/ ... xTheGuide#


3- After you will make all on those 2 process , you will have to un install the Game First from the wine.
Then Delete the file from the program files on wine.
Then please run the Anti Virus on the Path of the Directory on wine.

4- after you will Restart the machine at the end of all above , see if you can install the Game.
If you will have the same Results then it looks like Cell & myself are right on this issue.
send me PM please - I will Guide you to one more way.
Admin-Amir
 


Return to Ultimate Edition 2.5

Who is online

Users browsing this forum: No registered users and 2 guests

cron