Are you a spammer

Please note, that the first 3 posts you make, will need to be approved by a forum Administrator or Moderator before they are publicly viewable.
Each application to join this forum is checked at the Stop Forum Spam website. If the email or IP address appears there when checked, you will not be allowed to join this forum.
If you get past this check and post spam on this forum, your posts will be immediately deleted and your account inactivated.You will then be banned and your IP will be submitted to your ISP, notifying them of your spamming. So your spam links will only be seen for an hour or two at most. In other words, don't waste your time and ours.

This forum is for the use and enjoyment of the members and visitors looking to learn about and share information regarding the topics listed. It is not a free-for-all advertising venue. Your time would be better spent pursuing legitimate avenues of promoting your websites.

GNURadio install help please!

The Ultimate Guide for the rest of us


GNURadio install help please!

Postby OlDrunk » Tue Jul 17, 2012 1:22 am

I'm pulling my hair out over this, I got one those rtl-sdr usb dongles( super cheap 'Software Defined Radio' ) and trying to install GNURadio and it's just driving me mad. I'm running Ultimate Edition 2.6.5 and the dependency issues for GNUradio are just insane I getting stuff that won't install because it needs another dependency thats already installed, it needs libpulse-dev installed but it will not install because it's dependencies are installed????WTF???? but if I remove them then it won't install because they are not there????. My Question is any one here get GNU radio to build on Ultimate Edition or know how to get it to build?? I've never had this much trouble trying to build and install something from source before.

Thanks for any help at all or just for taking the time to read this post.
- Cheers!
Laptop: MSI GE70 0ND-032US(2012)
Intel Core i7 - 3610QM / RAM DDR3 8GB / Intel HD Graphics 4000
Nvidia GeForce GTX660M / 2GB GDDR5
HDD: 1TB / SSD: N/A
OS : Ultimate Edition 5.0 LTS 64Bit
Desktop: Too old to boot, R.I.P first gen AMD64 duel core.
User avatar
OlDrunk
U.E. Knowledgable
U.E. Knowledgable
 
Posts: 26
Joined: Thu May 19, 2011 1:24 am
Location: Wastelands
Operating System: Ultimate Edition 3.4 64 BIT



Re: GNURadio install help please!

Postby stlsaint » Tue Jul 17, 2012 1:28 pm

Lets get some more info on your issue. Paste the output into a site such as http://paste.ubuntu.com/ and paste the url here so we can get a full view of your issue.

Also im assuming you are trying this process via the gnuradio install site?

Using the build-gnuradio script¶
The build-gnuradio is an install script for recent Fedora and Ubuntu systems provided by Marcus Leech. For most users, this is the recommended way.

For the impatient: open a terminal window, move to the directory you would like the source files to be stored (e.g. 'cd src/') and run this command:


$ wget http://www.sbrac.org/files/build-gnuradio && chmod a+x ./build-gnuradio && ./build-gnuradio

This downloads the installer (build-gnuradio) and makes it executable. It then downloads and installs all dependencies, downloads both UHD and GNU Radio from git (which means it will automatically install the latest version from the 'main' branch), runs the make process and installs it on your system. In most cases, simply running the script will do all you need to get a running GNU Radio system built from source. Also, you still have all the source code lying on your hard disk and therefore available for future modifications. It combines the flexibility of installing from source with the ease of using binaries and is recommended for most users of Ubuntu and Fedora.

Thanks to Marcus Leech for putting this together and hosting it.
intel centr duo
nvidia 8400 graphics
4GB ram, 500gb hdd
Ultimate Edition on Freenode @ IRC #UltimateEdition
User avatar
stlsaint
Moderator
 
Posts: 131
Joined: Sat Jul 18, 2009 11:43 pm
Location: Dayton, OH
Age: 32
Operating System: Ultimate Edition 3.2 64 BIT



Re: GNURadio install help please!

Postby OlDrunk » Tue Jul 17, 2012 9:03 pm

Thank you for the reply and trying to help, here is pastebin with the output, I ran the script with the verbose option to get some output
http://paste.ubuntu.com/1097611/

Sorry for the lack of replies......any luck?
- Cheers!
Laptop: MSI GE70 0ND-032US(2012)
Intel Core i7 - 3610QM / RAM DDR3 8GB / Intel HD Graphics 4000
Nvidia GeForce GTX660M / 2GB GDDR5
HDD: 1TB / SSD: N/A
OS : Ultimate Edition 5.0 LTS 64Bit
Desktop: Too old to boot, R.I.P first gen AMD64 duel core.
User avatar
OlDrunk
U.E. Knowledgable
U.E. Knowledgable
 
Posts: 26
Joined: Thu May 19, 2011 1:24 am
Location: Wastelands
Operating System: Ultimate Edition 3.4 64 BIT



Re: GNURadio install help please!

Postby stlsaint » Tue Aug 07, 2012 7:23 pm

This:

Code: Select all
 The following packages have unmet dependencies:
 libasound2-dev : Depends: libasound2 (= 1.0.23-1ubuntu2)
 libboost-all-dev : Depends: libboost-iostreams-dev but it is not going to be installed
                    Depends: libboost-regex-dev but it is not going to be installed
 libpulse-dev : Depends: libpulse0 (= 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu21) but 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu21.1 is to be installed
                Depends: libpulse-mainloop-glib0 (= 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu21) but 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu21.1 is to be installed
                Depends: libpulse-browse0 (= 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu21) but 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu21.1 is to be installed
                Depends: libavahi-client-dev but it is not going to be installed
E: Broken packages


Amongst other stuff like multiple sitings of errors like these:
Code: Select all
 Could NOT find Docutils  (missing:  RST2HTML_EXECUTABLE)
--
-- Configuring Manual support...
--   Dependency DOCUTILS_FOUND = FALSE
--   Disabling Manual support.
--   Override with -DENABLE_MANUAL=ON/OFF
--
-- Could NOT find Doxygen  (missing:  DOXYGEN_EXECUTABLE)
--
-- Configuring Doxygen support...
--   Dependency DOXYGEN_FOUND = NO
--   Disabling Doxygen support.
--   Override with -DENABLE_DOXYGEN=ON/OFF


Lead me to believe that some dependencies are not being met with packages or the build process. I would take this up with the site personnel, maybe a contact form or bug report of forum of some sort.
intel centr duo
nvidia 8400 graphics
4GB ram, 500gb hdd
Ultimate Edition on Freenode @ IRC #UltimateEdition
User avatar
stlsaint
Moderator
 
Posts: 131
Joined: Sat Jul 18, 2009 11:43 pm
Location: Dayton, OH
Age: 32
Operating System: Ultimate Edition 3.2 64 BIT


Return to Newbie's Corner

Who is online

Users browsing this forum: No registered users and 1 guest