Guinea Pig wanted (OVER)

Source code I have written openly published for your viewing pleasure.


Re: Guinea Pig wanted

Postby Tool » Sat Jun 01, 2013 1:55 am

Well, this is what I got. Hope I ran it right. :/

fatal: destination path 'kiss-script' already exists and is not an empty directory.
root@****i# cd kiss-script
root@****/kiss-script# time bash build-2.sh
[+] apt-get update
Ign cdrom://[Debian GNU/Linux 7.0.0 _Wheezy_ - Official amd64 DVD Binary-1 20130504-14:44] wheezy Release.gpg
Ign cdrom://[Debian GNU/Linux 7.0.0 _Wheezy_ - Official amd64 DVD Binary-1 20130504-14:44] wheezy Release
Ign cdrom://[Debian GNU/Linux 7.0.0 _Wheezy_ - Official amd64 DVD Binary-1 20130504-14:44] wheezy/contrib amd64 Packages/DiffIndex
Ign cdrom://[Debian GNU/Linux 7.0.0 _Wheezy_ - Official amd64 DVD Binary-1 20130504-14:44] wheezy/main amd64 Packages/DiffIndex
Ign cdrom://[Debian GNU/Linux 7.0.0 _Wheezy_ - Official amd64 DVD Binary-1 20130504-14:44] wheezy/contrib Translation-en_US
Ign cdrom://[Debian GNU/Linux 7.0.0 _Wheezy_ - Official amd64 DVD Binary-1 20130504-14:44] wheezy/main Translation-en_US
Hit http://ftp.us.debian.org wheezy Release.gpg
Hit http://security.debian.org wheezy/updates Release.gpg
Hit http://ftp.us.debian.org wheezy-updates Release.gpg
Hit http://security.debian.org wheezy/updates Release
Hit http://ftp.us.debian.org wheezy Release
Hit http://security.debian.org wheezy/updates/main Sources
Hit http://ftp.us.debian.org wheezy-updates Release
Hit http://security.debian.org wheezy/updates/contrib Sources
Hit http://ftp.us.debian.org wheezy/main Sources
Hit http://security.debian.org wheezy/updates/non-free Sources
Hit http://ftp.us.debian.org wheezy/non-free Sources
Hit http://security.debian.org wheezy/updates/main amd64 Packages
Hit http://ftp.us.debian.org wheezy/contrib Sources
Hit http://security.debian.org wheezy/updates/contrib amd64 Packages
Hit http://ftp.us.debian.org wheezy/main amd64 Packages
Hit http://security.debian.org wheezy/updates/non-free amd64 Packages
Hit http://ftp.us.debian.org wheezy/non-free amd64 Packages
Hit http://security.debian.org wheezy/updates/contrib Translation-en
Hit http://ftp.us.debian.org wheezy/contrib amd64 Packages
Hit http://security.debian.org wheezy/updates/main Translation-en
Hit http://ftp.us.debian.org wheezy/contrib Translation-en
Hit http://security.debian.org wheezy/updates/non-free Translation-en
Hit http://ftp.us.debian.org wheezy/main Translation-en
Hit http://ftp.us.debian.org wheezy/non-free Translation-en
Hit http://ftp.us.debian.org wheezy-updates/main Sources
Hit http://ftp.us.debian.org wheezy-updates/contrib Sources
Hit http://ftp.us.debian.org wheezy-updates/non-free Sources
Hit http://ftp.us.debian.org wheezy-updates/main amd64 Packages
Hit http://ftp.us.debian.org wheezy-updates/contrib amd64 Packages
Hit http://ftp.us.debian.org wheezy-updates/non-free amd64 Packages
Hit http://ftp.us.debian.org wheezy-updates/contrib Translation-en
Hit http://ftp.us.debian.org wheezy-updates/main Translation-en
Hit http://ftp.us.debian.org wheezy-updates/non-free Translation-en
Reading package lists... Done
[+] apt-get install libzbar-dev g++ libqscintilla2-dev cmake codeblocks libopencv-* libqt4-* -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libopencv-legacy-dev' for regex 'libopencv-*'
Note, selecting 'libopencv-gpu-dev' for regex 'libopencv-*'
Note, selecting 'libopencv-legacy2.3' for regex 'libopencv-*'
Note, selecting 'libopencv-imgproc2.3' for regex 'libopencv-*'
Note, selecting 'libopencv-imgproc-dev' for regex 'libopencv-*'
Note, selecting 'libopencv-highgui-dev' for regex 'libopencv-*'
Note, selecting 'libopencv-objdetect2.3' for regex 'libopencv-*'
Note, selecting 'libopencv-calib3d2.3' for regex 'libopencv-*'
Note, selecting 'libopencv-contrib-dev' for regex 'libopencv-*'
Note, selecting 'libopencv-ml2.3' for regex 'libopencv-*'
Note, selecting 'libopencv-features2d2.3' for regex 'libopencv-*'
Note, selecting 'libopencv-video-dev' for regex 'libopencv-*'
Note, selecting 'libopencv-video2.3' for regex 'libopencv-*'
Note, selecting 'libopencv-core2.3' for regex 'libopencv-*'
Note, selecting 'libopencv-flann2.3' for regex 'libopencv-*'
Note, selecting 'libopencv-gpu2.3' for regex 'libopencv-*'
Note, selecting 'libopencv-core-dev' for regex 'libopencv-*'
Note, selecting 'libopencv-objdetect-dev' for regex 'libopencv-*'
Note, selecting 'libopencv-calib3d-dev' for regex 'libopencv-*'
Note, selecting 'libopencv-dev' for regex 'libopencv-*'
Note, selecting 'libopencv-doc' for regex 'libopencv-*'
Note, selecting 'libopencv-ml-dev' for regex 'libopencv-*'
Note, selecting 'libopencv-contrib2.3' for regex 'libopencv-*'
Note, selecting 'libopencv-features2d-dev' for regex 'libopencv-*'
Note, selecting 'libopencv-highgui2.3' for regex 'libopencv-*'
Note, selecting 'libopencv-flann-dev' for regex 'libopencv-*'
Note, selecting 'libqt4-declarative' for regex 'libqt4-*'
Note, selecting 'libqt4-sql-psql' for regex 'libqt4-*'
Note, selecting 'libqt4-xmlpatterns-dbg' for regex 'libqt4-*'
Note, selecting 'libqt4-sql-ibase' for regex 'libqt4-*'
Note, selecting 'libqt4-qt3support' for regex 'libqt4-*'
Note, selecting 'libqt4-phonon' for regex 'libqt4-*'
Note, selecting 'libqt4-debug' for regex 'libqt4-*'
Note, selecting 'libqt4-sql-sqlite2' for regex 'libqt4-*'
Note, selecting 'libqt4-opengl-dev' for regex 'libqt4-*'
Note, selecting 'libqt4-declarative-gestures' for regex 'libqt4-*'
Note, selecting 'libqt4-test' for regex 'libqt4-*'
Note, selecting 'libqt4-script' for regex 'libqt4-*'
Note, selecting 'libqt4-designer' for regex 'libqt4-*'
Note, selecting 'libqt4-network' for regex 'libqt4-*'
Note, selecting 'libqt4-dbus' for regex 'libqt4-*'
Note, selecting 'libqt4-ruby' for regex 'libqt4-*'
Note, selecting 'libqt4-core' for regex 'libqt4-*'
Note, selecting 'libqt4-opengl' for regex 'libqt4-*'
Note, selecting 'libqt4-declarative-folderlistmodel' for regex 'libqt4-*'
Note, selecting 'libqt4pas5' for regex 'libqt4-*'
Note, selecting 'libqt4pas-dev' for regex 'libqt4-*'
Note, selecting 'libqt4-xmlpatterns' for regex 'libqt4-*'
Note, selecting 'libqt4-sql-sqlite' for regex 'libqt4-*'
Note, selecting 'libqt4-dbg' for regex 'libqt4-*'
Note, selecting 'libqt4-dev' for regex 'libqt4-*'
Note, selecting 'libqt4-help' for regex 'libqt4-*'
Note, selecting 'libqt4-gui' for regex 'libqt4-*'
Note, selecting 'libqt4-sql-tds' for regex 'libqt4-*'
Note, selecting 'libqt4-sql' for regex 'libqt4-*'
Note, selecting 'libqt4-declarative-particles' for regex 'libqt4-*'
Note, selecting 'libqt4-svg' for regex 'libqt4-*'
Note, selecting 'libqt4-dev-bin' for regex 'libqt4-*'
Note, selecting 'libqt4-xml' for regex 'libqt4-*'
Note, selecting 'libqt4-assistant' for regex 'libqt4-*'
Note, selecting 'libqt4-ruby1.8' for regex 'libqt4-*'
Note, selecting 'libqt4-private-dev' for regex 'libqt4-*'
Note, selecting 'libqt4-script-dbg' for regex 'libqt4-*'
Note, selecting 'libqt4-sql-odbc' for regex 'libqt4-*'
Note, selecting 'libqt4-qt3support-dbg' for regex 'libqt4-*'
Note, selecting 'libqt4-webkit' for regex 'libqt4-*'
Note, selecting 'libqt4-declarative-shaders' for regex 'libqt4-*'
Note, selecting 'libqt4-sql-mysql' for regex 'libqt4-*'
Note, selecting 'libqt4-scripttools' for regex 'libqt4-*'
Note, selecting 'libqt4-webkit-dbg' for regex 'libqt4-*'
Note, selecting 'libqt4-designer-dbg' for regex 'libqt4-*'
libqt4-xml is already the newest version.
libqt4-xml set to manually installed.
libqt4-network is already the newest version.
libqt4-network set to manually installed.
libqt4-dbus is already the newest version.
libqt4-dbus set to manually installed.
libqt4-svg is already the newest version.
libqt4-svg set to manually installed.
libqt4-script is already the newest version.
libqt4-script set to manually installed.
libqt4-sql is already the newest version.
libqt4-sql set to manually installed.
libqt4-xmlpatterns is already the newest version.
libqt4-xmlpatterns set to manually installed.
libqt4-declarative is already the newest version.
libqt4-declarative set to manually installed.
libqt4-opengl is already the newest version.
libqt4-opengl set to manually installed.
libqt4-designer is already the newest version.
libqt4-designer set to manually installed.
libqt4-qt3support is already the newest version.
libqt4-qt3support set to manually installed.
libqt4-sql-mysql is already the newest version.
libqt4-sql-mysql set to manually installed.
libqt4-help is already the newest version.
libqt4-help set to manually installed.
libqt4-scripttools is already the newest version.
libqt4-scripttools set to manually installed.
libqt4-test is already the newest version.
libqt4-test set to manually installed.
libqt4-sql-sqlite is already the newest version.
libqt4-sql-sqlite set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libqt4-ruby1.8 : Depends: ruby-phonon but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
yum not found. This system is not RHEL based.
I detect cmake. Proceeding.
/home/levi/kiss-script/libkar
build-2.sh: line 241: cmake: command not found
make: *** No targets specified and no makefile found. Stop.
An erro hasr occured at line : build-2.sh:
I have been killed. Exiting.

real 0m27.853s
user 0m1.856s
sys 0m0.204s
HP m7277c PC, 3GB DDR2 RAM, 3.00GHz dual core Pentium D
Geforce 210 Silent Graphics card w/1GB
2x300 GB SATA HDD's (No RAID) LG & HP DVD burners

HP Pavilion dv4 Entertainment PC (Laptop)
2.10 dual core AMD Turion X2
ATI Radeon HD 3200, DVD Burner, Wifi, Bluetooth
QL Touch controls, Altec Lansing onboard speakers

Rooted LG Motion 4G, 1.5GHz dual core
1GB RAM, 8GB ROM

MetroPCS ZTE Z730 Concord 2
User avatar
Tool
U.E. Pro
U.E. Pro
 
Posts: 146
Joined: Tue Apr 23, 2013 2:42 pm
Location: Sacramento
Age: 36
Operating System: Ultimate Edition 3.5 64 BIT



Re: Guinea Pig wanted

Postby ryanvade » Sat Jun 01, 2013 5:52 pm

Hmm. Issues with dependencies. You ran the script fine. I just need to refine some things. I will try to make some room on a desktop somewhere to test this. Some dependencies definitely are not needed. Especially qt4-ruby.

Thank you.

Oh, and just a note for you. If you get scripts from people, I don't recommend running them as root. If the script is good, it will tell you what it is going to do and use SUDO.
Image

Laptop: HP dv6t-7000 CTO Desktop: Compaq Presario SR21632wm
i5 2450m Pentium D 960 @ 4 GHz
6 GB ram 2 GB ram
Intel HD 3000 Graphics / Nvidia GT 630M Nvidia GT 520 @ 820 MHz
Diamond II-B 3.10-rc4/Windows 7 Home Premium KDE | Windows 7 Starter/Arch Linux

Paid supporter of the Linux Foundation
User avatar
ryanvade
Moderator
 
Posts: 499
Joined: Sat Apr 28, 2012 10:54 am
Operating System: Other Linux



Re: Guinea Pig wanted

Postby Tool » Sat Jun 01, 2013 6:11 pm

ryanvade wrote:Hmm. Issues with dependencies. You ran the script fine. I just need to refine some things. I will try to make some room on a desktop somewhere to test this. Some dependencies definitely are not needed. Especially qt4-ruby.

Thank you.

Oh, and just a note for you. If you get scripts from people, I don't recommend running them as root. If the script is good, it will tell you what it is going to do and use SUDO.

Noted. This was a turn-n-burn install though to help you out. I don't like it. LOL. I had 3.5 installed in that tower, but messed up on some upgrades, so Netflix and a few other things didn't work and was planning a re-install anyways. :D
HP m7277c PC, 3GB DDR2 RAM, 3.00GHz dual core Pentium D
Geforce 210 Silent Graphics card w/1GB
2x300 GB SATA HDD's (No RAID) LG & HP DVD burners

HP Pavilion dv4 Entertainment PC (Laptop)
2.10 dual core AMD Turion X2
ATI Radeon HD 3200, DVD Burner, Wifi, Bluetooth
QL Touch controls, Altec Lansing onboard speakers

Rooted LG Motion 4G, 1.5GHz dual core
1GB RAM, 8GB ROM

MetroPCS ZTE Z730 Concord 2
User avatar
Tool
U.E. Pro
U.E. Pro
 
Posts: 146
Joined: Tue Apr 23, 2013 2:42 pm
Location: Sacramento
Age: 36
Operating System: Ultimate Edition 3.5 64 BIT



Re: Guinea Pig wanted

Postby ryanvade » Sun Jun 02, 2013 2:45 am

I made changes to the dependencies. It should work now...
Image

Laptop: HP dv6t-7000 CTO Desktop: Compaq Presario SR21632wm
i5 2450m Pentium D 960 @ 4 GHz
6 GB ram 2 GB ram
Intel HD 3000 Graphics / Nvidia GT 630M Nvidia GT 520 @ 820 MHz
Diamond II-B 3.10-rc4/Windows 7 Home Premium KDE | Windows 7 Starter/Arch Linux

Paid supporter of the Linux Foundation
User avatar
ryanvade
Moderator
 
Posts: 499
Joined: Sat Apr 28, 2012 10:54 am
Operating System: Other Linux



Re: Guinea Pig wanted

Postby Tool » Sun Jun 02, 2013 2:54 am

ryanvade wrote:I made changes to the dependencies. It should work now...

To test this again, do I need to re-install? Or can I pick up where I left off? I have made no other alterations to the Debian.
HP m7277c PC, 3GB DDR2 RAM, 3.00GHz dual core Pentium D
Geforce 210 Silent Graphics card w/1GB
2x300 GB SATA HDD's (No RAID) LG & HP DVD burners

HP Pavilion dv4 Entertainment PC (Laptop)
2.10 dual core AMD Turion X2
ATI Radeon HD 3200, DVD Burner, Wifi, Bluetooth
QL Touch controls, Altec Lansing onboard speakers

Rooted LG Motion 4G, 1.5GHz dual core
1GB RAM, 8GB ROM

MetroPCS ZTE Z730 Concord 2
User avatar
Tool
U.E. Pro
U.E. Pro
 
Posts: 146
Joined: Tue Apr 23, 2013 2:42 pm
Location: Sacramento
Age: 36
Operating System: Ultimate Edition 3.5 64 BIT



Re: Guinea Pig wanted

Postby ryanvade » Sun Jun 02, 2013 3:00 am

No changes needed. I was also able to make room for a VM install of Debian. 10mb of free space left...It worked fine there. A VM is nice but an actual install is always preferred.
Image

Laptop: HP dv6t-7000 CTO Desktop: Compaq Presario SR21632wm
i5 2450m Pentium D 960 @ 4 GHz
6 GB ram 2 GB ram
Intel HD 3000 Graphics / Nvidia GT 630M Nvidia GT 520 @ 820 MHz
Diamond II-B 3.10-rc4/Windows 7 Home Premium KDE | Windows 7 Starter/Arch Linux

Paid supporter of the Linux Foundation
User avatar
ryanvade
Moderator
 
Posts: 499
Joined: Sat Apr 28, 2012 10:54 am
Operating System: Other Linux



Re: Guinea Pig wanted

Postby Tool » Sun Jun 02, 2013 3:05 am

ryanvade wrote:No changes needed. I was also able to make room for a VM install of Debian. 10mb of free space left...It worked fine there. A VM is nice but an actual install is always preferred.

Well, I can run it for you again then since it is still installed. Won't take but a few minutes.
HP m7277c PC, 3GB DDR2 RAM, 3.00GHz dual core Pentium D
Geforce 210 Silent Graphics card w/1GB
2x300 GB SATA HDD's (No RAID) LG & HP DVD burners

HP Pavilion dv4 Entertainment PC (Laptop)
2.10 dual core AMD Turion X2
ATI Radeon HD 3200, DVD Burner, Wifi, Bluetooth
QL Touch controls, Altec Lansing onboard speakers

Rooted LG Motion 4G, 1.5GHz dual core
1GB RAM, 8GB ROM

MetroPCS ZTE Z730 Concord 2
User avatar
Tool
U.E. Pro
U.E. Pro
 
Posts: 146
Joined: Tue Apr 23, 2013 2:42 pm
Location: Sacramento
Age: 36
Operating System: Ultimate Edition 3.5 64 BIT



Re: Guinea Pig wanted

Postby ryanvade » Sun Jun 02, 2013 10:40 pm

kool thanks.
Image

Laptop: HP dv6t-7000 CTO Desktop: Compaq Presario SR21632wm
i5 2450m Pentium D 960 @ 4 GHz
6 GB ram 2 GB ram
Intel HD 3000 Graphics / Nvidia GT 630M Nvidia GT 520 @ 820 MHz
Diamond II-B 3.10-rc4/Windows 7 Home Premium KDE | Windows 7 Starter/Arch Linux

Paid supporter of the Linux Foundation
User avatar
ryanvade
Moderator
 
Posts: 499
Joined: Sat Apr 28, 2012 10:54 am
Operating System: Other Linux



Re: Guinea Pig wanted

Postby Tool » Tue Jun 04, 2013 1:46 am

ryanvade wrote:kool thanks.

Sorry about the late response. Got sick. I should have the results tomorrow
HP m7277c PC, 3GB DDR2 RAM, 3.00GHz dual core Pentium D
Geforce 210 Silent Graphics card w/1GB
2x300 GB SATA HDD's (No RAID) LG & HP DVD burners

HP Pavilion dv4 Entertainment PC (Laptop)
2.10 dual core AMD Turion X2
ATI Radeon HD 3200, DVD Burner, Wifi, Bluetooth
QL Touch controls, Altec Lansing onboard speakers

Rooted LG Motion 4G, 1.5GHz dual core
1GB RAM, 8GB ROM

MetroPCS ZTE Z730 Concord 2
User avatar
Tool
U.E. Pro
U.E. Pro
 
Posts: 146
Joined: Tue Apr 23, 2013 2:42 pm
Location: Sacramento
Age: 36
Operating System: Ultimate Edition 3.5 64 BIT



Re: Guinea Pig wanted

Postby ryanvade » Wed Jun 12, 2013 10:43 pm

You know what? After all the work I put into fixing this crappy bit of software, the KIPR community has not given me a nice "Thank You". Just a developer saying sorry that he makes things difficult. :x I am stopping development on this script. Not planning on deleting it though either.


One word for those students, GET ARDUINO!!!!!!!!
Image

Laptop: HP dv6t-7000 CTO Desktop: Compaq Presario SR21632wm
i5 2450m Pentium D 960 @ 4 GHz
6 GB ram 2 GB ram
Intel HD 3000 Graphics / Nvidia GT 630M Nvidia GT 520 @ 820 MHz
Diamond II-B 3.10-rc4/Windows 7 Home Premium KDE | Windows 7 Starter/Arch Linux

Paid supporter of the Linux Foundation
User avatar
ryanvade
Moderator
 
Posts: 499
Joined: Sat Apr 28, 2012 10:54 am
Operating System: Other Linux

PreviousNext

Return to Programming

Who is online

Users browsing this forum: No registered users and 1 guest