Usplash Maker 1.03

Source code I have written openly published for your viewing pleasure.

Did you find this source useful / informative?

Yes
16
94%
No
1
6%
 
Total votes : 17



Re: Usplash Maker

Postby TheeMahn » Fri Sep 12, 2008 3:40 am

red_team316 wrote:TheeMahn:
No problem. If Ultimatix works as good as everybody is touting, then I would think that should be the higher priority. After all, it's a very big part of Ultimate Edition. Not sure what you consider finished, I'm not exactly sure what the scope of the project entails.

golinux:
While I'm sure we wouldn't mind you buying us a coffee or beer, it just doesn't seem practical. You see, money isn't really the factor here, time is.
TheeMahn wrote:I don't have time

In fact I read something not too long ago about somebody that contributed several hundred dollars to an open source project just to find out that the money is lying dormant and most likely wont be used. There were other reasons involved but time was a big one. Sure, I suppose we could buy ourselves faster computers so the code will compile faster(lol) but that isn't actually producing anything towards the project goals, not to mention I know TheeMahn and I are rocking some pretty decent boxes that are quite capable as it is. I will be building a new box pretty soon only because I sold this one to my bro. That will take time away from any work on any coding(usplash-maker or reconstructor). Heck, right now I'm even working with the LiveUSB dev Simon Peter(gave him a bugfix so that DVD iso's could be mounted and used, Ultimate1.9 was my test iso) and I don't even consider myself a dev for that project.

Okay as far as getting it to work:
I personally think that posting workarounds for the current code would be a waste of time. The code should 'just work', and in it's current state it just doesn't work for alot of people. Some of the code I have done now could be meshed with the current script for a better fix, maybe I'll see if I can fix it up this weekend just for something to get by until the full version is finished.


I will not BS you, I dropped Ultimate Edition theme pack this eve, I have recently moved and had nothing better to do with my time as I had no internet. I revised and dropped Ultamatix -4 to the main site (reason it was down bandwidth exceeded), most people are oblivious to what I am about to say err type, I get pounded traffic wise 1 million hits in a day one site, I have 8, it does bother me that I do not have the time to address everyones situation, but I do try to make one issue melt away at a time, please remember I am but 1 man. I see this as an issue that can't be resolved @ least via google standards (what does not exist), did you know I also do the same for others that don't know how the debian system works? Exclusive hosting of files that "just do not exist?" Many I have packaged for them, maintainer if you will.

Wait until you see 2.0 of Ultimate Edition, you will (means you will in english) understand, autorun at it's finest, be it windows or otherwise.
Home of Ultimate Edition. Got a question? Please review the F.A.Q. Browse the How to section.

Main O/S: Builder of O/S Guess.
Mainboard: ASUS Hero VI (AM4)
CPU: AMD 1700X water cooled (Deepcool Captain Genome Cooling tower)
Ram: 16 GB GSkill Trident RGB Series Dual Channel DDR4 3200
Video: MSI RX470 8GB Gaming card.
Hard Disks: MASSIVE on the network.(10 Gigabit, 48 port, multiple servers)
Monitors: 4K Samsung 28", HannsG HH281, Various others
750 Watt modular PSU (Rosswell)
1100 Watt Amp & 4 X 600 Watt speakers

Servers in the basement.
User avatar
TheeMahn
Site Admin
 
Posts: 4199
Joined: Fri Oct 12, 2007 10:02 am
Location: U.S.A.
Age: 47
Operating System: Ultimate Edition Developer



Re: Usplash Maker

Postby golinux » Fri Sep 12, 2008 10:52 am

Okay as far as getting it to work:
I personally think that posting workarounds for the current code would be a waste of time. The code should 'just work', and in it's current state it just doesn't work for alot of people. Some of the code I have done now could be meshed with the current script for a better fix, maybe I'll see if I can fix it up this weekend just for something to get by until the full version is finished.

I realize that sometimes there just aren't enough hours in the day. Just wait - you're still a young'un. Time seems to contract and accelerate as the years go by!!

If you could piece something together that would be great! If not, there isn't a tremendous rush because I currently have a working version on my primary box. However, Ibex is coming out soon and if it doesn't have any major bugs (Hardy has some I don't want to deal with), I will be contemplating an upgrade around the first of the year.

Sending lot's of virtual beer and coffee . . . <BREW>
User avatar
golinux
U.E. Knowledgable
U.E. Knowledgable
 
Posts: 28
Joined: Sun May 25, 2008 9:12 pm
Location: Linuxland
Operating System: Ultimate Edition KDE4



Re: Usplash Maker

Postby golinux » Sat Sep 13, 2008 11:18 am

red_team316 wrote:Alex: Are you sure it's not putting it in another directory and you're just not finding it? If you still can't find it, open up the bash script and comment out the lines at the bottom so they look like this. That should leave the .so file in the WorkInProgress directory so you can copy it elsewhere yourself.
Code: Select all
#mv usplash-theme-ubuntu.so ../$OUTFILE
cd ..
#Clean up
#rm -R WorkInProgress

FYI, when I tried this, it left the WorkInProgress directory (including all the script-generated .pngs in various sizes) in the folder but no .so file was to be found.
User avatar
golinux
U.E. Knowledgable
U.E. Knowledgable
 
Posts: 28
Joined: Sun May 25, 2008 9:12 pm
Location: Linuxland
Operating System: Ultimate Edition KDE4



Re: Usplash Maker 1.03

Postby wladicus » Mon Dec 08, 2008 4:04 pm

Hi TheeMahn,
I am a newbie, so the problem is likely due to my miscomprehension rather than anything that you have supplied on this forum.
Maybe you can point out to me what I should do to make this work. I downloaded usplash-maker and installed nautilus (as it was not included in my Kubuntu 8.04.1). Then I right-clicked on my image file and then selected and left-clicked on usplash-maker. The program starts to run - the first small screen pops up telling me what the program is going to do. After I click to continue the same pop-up screen appears again and I click to continue again, and then the process continues until the last screen which tells me that it is 'Processing' (but nothing else happens on that pop-up) and then within about 3 seconds the program ends and there is no resulting '.so' file as expected. I tried this several times, but nothing happens.
Can you help me out please. :)
Thank you,
walt
walt,
_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_kubuntu 8.04.1 LTS (Hardy Heron)_/_/_/
St. Thomas, Ontario = 42.77° N, 81.11° W =
Royal Astronomical Society of Canada (RASC)
User avatar
wladicus
U.E. Newbie
U.E. Newbie
 
Posts: 8
Joined: Mon Dec 08, 2008 2:45 am
Location: St. Thomas, Ontario, Canada = 42.77° N, 81.11° W =
Age: 71
Operating System: Ultimate Edition 2.0 32 BIT



Re: Usplash Maker 1.03

Postby red_team316 » Tue Dec 09, 2008 8:18 pm

wladicus: Try using the 1.04 version instead. It is more current and should work a bit better :)

Here's the thread:
viewtopic.php?f=23&t=1767
Core i7 920(working on a decent OC), x58 ASUS P6T Deluxe V2, 6GB DDR3 1600, EVGA 8800GTS512, Silencer 750W PSU, CoolerMaster V8, Red Antec900
Image
User avatar
red_team316
U.E. College Professor
U.E. College Professor
 
Posts: 288
Joined: Mon Jan 07, 2008 12:37 am
Age: 34
Operating System: Ultimate Edition 3.2 64 BIT



Re: Usplash Maker 1.03

Postby wladicus » Tue Dec 09, 2008 11:22 pm

Thank you for the reply red_team316.
I tried the new version but had no luck. I probably do not understand a lot yet (as a newbie).
I finally followed the run in Terminal instructions and got the following error printout.
600X400|640X480|800X600|1024X768|1280X1024
--22:08:56-- http://ubuntusoftware.info/scripts/USpl ... ATA.tar.gz
=> `TUM-DATA.tar.gz'
Resolving ubuntusoftware.info... 68.178.254.22
Connecting to ubuntusoftware.info|68.178.254.22|:80... connected.
HTTP request sent, awaiting response... 404
22:08:57 ERROR 404: (no description).

mkdir: cannot create directory `/home/wladicus/TUM': File exists
cp: cannot stat `TUM-DATA.tar.gz': No such file or directory
tar: TUM-DATA.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
convert: unable to open image `usplash/usplash.png': No such file or directory.
600X400|640X480|800X600|1024X768|1280X1024
/bin/bash: usplashmagick-prepareimages: No such file or directory
mv: cannot stat `usplash/usplash_640x400.png': No such file or directory
mv: cannot stat `usplash/usplash_throbber_fore.png': No such file or directory
mv: cannot stat `usplash/usplash_throbber_back.png': No such file or directory
600X400|640X480|800X600|1024X768|1280X1024
/bin/bash: usplashmagick-prepareimages: No such file or directory
mv: cannot stat `usplash/usplash_640x480.png': No such file or directory
mv: cannot stat `usplash/usplash_throbber_fore.png': No such file or directory
mv: cannot stat `usplash/usplash_throbber_back.png': No such file or directory
600X400|640X480|800X600|1024X768|1280X1024
/bin/bash: usplashmagick-prepareimages: No such file or directory
mv: cannot stat `usplash/usplash_800x600.png': No such file or directory
mv: cannot stat `usplash/usplash_throbber_fore.png': No such file or directory
mv: cannot stat `usplash/usplash_throbber_back.png': No such file or directory
600X400|640X480|800X600|1024X768|1280X1024
/bin/bash: usplashmagick-prepareimages: No such file or directory
mv: cannot stat `usplash/usplash_1024x768.png': No such file or directory
mv: cannot stat `usplash/usplash_throbber_fore.png': No such file or directory
mv: cannot stat `usplash/usplash_throbber_back.png': No such file or directory
600X400|640X480|800X600|1024X768|1280X1024
/bin/bash: usplashmagick-prepareimages: No such file or directory
mv: cannot stat `usplash/usplash_1280x1024.png': No such file or directory
mv: cannot stat `usplash/usplash_throbber_fore.png': No such file or directory
mv: cannot stat `usplash/usplash_throbber_back.png': No such file or directory
Make Usplash 1.04: line 293: cd: WorkInProgress: No such file or directory
600X400|640X480|800X600|1024X768|1280X1024
600X400|640X480|800X600|1024X768|1280X1024
600X400|640X480|800X600|1024X768|1280X1024
600X400|640X480|800X600|1024X768|1280X1024
600X400|640X480|800X600|1024X768|1280X1024
600X400|640X480|800X600|1024X768|1280X1024
600X400|640X480|800X600|1024X768|1280X1024
600X400|640X480|800X600|1024X768|1280X1024
600X400|640X480|800X600|1024X768|1280X1024
600X400|640X480|800X600|1024X768|1280X1024
600X400|640X480|800X600|1024X768|1280X1024
600X400|640X480|800X600|1024X768|1280X1024
600X400|640X480|800X600|1024X768|1280X1024
1
600X400|640X480|800X600|1024X768|1280X1024
600X400|640X480|800X600|1024X768|1280X1024
make: *** No rule to make target `throbber_back_640_400.png.c.o', needed by `usplash-theme-ubuntu.so'. Stop.
mv: cannot stat `usplash-theme-ubuntu.so': No such file or directory
rm: cannot remove `usplash': No such file or directory
rm: cannot remove `usplashmagick-test': No such file or directory
rm: cannot remove `usplashmagick-prepareimages': No such file or directory
rm: cannot remove `TUM-DATA.tar.gz': No such file or directory
rm: cannot remove `WorkInProgress': No such file or directory

I do not know what it all means.
Can you help me? I would really like to make a usplash screen of my own design.
Thank you for your time.

walt
User avatar
wladicus
U.E. Newbie
U.E. Newbie
 
Posts: 8
Joined: Mon Dec 08, 2008 2:45 am
Location: St. Thomas, Ontario, Canada = 42.77° N, 81.11° W =
Age: 71
Operating System: Ultimate Edition 2.0 32 BIT



Re: Usplash Maker 1.03

Postby red_team316 » Wed Dec 10, 2008 12:04 am

Get rid of all instances of 1.03 script as you won't need it lingering around by accident. Forgive me, the 404 is obviously dead on. The site has been thru several overhauls for various reasons for awhile, I'll look into getting it uploaded. I left the attachment there that way you can install it manually too. Grab the TUM-DATA.tar.gz from the first post in the 1.04 thread and follow the instructions on where to place it. It appears that is the only problem I see. The fact that you did not have TUM-DATA caused a chain reaction of errors.


It's probably a good idea for you to continue the discussion there. I'll close this thread for now unless someone else sees fit to reopen it as it was split in the first place to separate the two and kept for changelog/archival purposes. See ya there!

Link to TUM 1.04 Download, Installation, and Discussion Thread
Core i7 920(working on a decent OC), x58 ASUS P6T Deluxe V2, 6GB DDR3 1600, EVGA 8800GTS512, Silencer 750W PSU, CoolerMaster V8, Red Antec900
Image
User avatar
red_team316
U.E. College Professor
U.E. College Professor
 
Posts: 288
Joined: Mon Jan 07, 2008 12:37 am
Age: 34
Operating System: Ultimate Edition 3.2 64 BIT

Previous

Return to Programming

Who is online

Users browsing this forum: No registered users and 2 guests

cron